Qterm and alternatives?

Started by TynH, 19:40, 25 March 20

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I'm playing around with my CPS8256 for the first time and it appears to be working. Connected a hayes compatible modem and this also works, partially at least. Unfortunately I can't get QTerm to accept any commands, everything typed just goes straight to CP/M:

Instead of "whatever works as command key" + B to set the baud rate I simply get an error. I must've tried every key by now!

Kermit sort of works but I never get much further than logging into BBSs etc before the modem resets, so not great either:

At least I managed to issue AT commands, speak to the modem and connect to my network using kermit!
I still don't get how Qterm's supposed to work though.


I used MEX.COM for a few years on the CPC and for a generic CPM program it was pretty good.
Maybe there is a PCW version available?


Was this the customised version of qterm for the PCW? (QTERMPCW.PMA at http://www.classiccmp.org/cpmarchives/cpm/mirrors/ftp.demon.com/pub/cpm/amstrad/ )
The character to set the baud rate appears to be Control-Backslash, and I think on the PCW that corresponds to alt-@.


Quote qterm5ae.com this special version of QTERM will run at up to 38400 baud on the Amstrad PCW

I've only tried 1200 baud yet and it needs EMU102 running as well (which does the VT100 translation AIU.


Sounds like I'm not the first to run into this problem though. Sounds like a fatal bug in the modem's firmware:



Okay, no matter which terminal software I tried, I couldn't get past login screens like this one:

In the end I tried changing the modem baud rate to 9600 (from its factory 1200 setting), logged off, changed terminal accordingly an re-connected.
So ummm... suddenly THAT seems to have helped:

Unfortunately it's now quite garbled and difficult to make sense of:

I guess I could fiddle with my settings some more, like parity, flow control etc.?
Actually I have no idea!


Quote from: ComSoft6128 on 19:47, 25 March 20
I used MEX.COM for a few years on the CPC and for a generic CPM program it was pretty good.
Maybe there is a PCW version available?
That's a great choice. Yes, there is a generic version somewhere.

TynH: Some of your screens look like scrambled, but after a while. Seems like there could be some disturbance in the connection.
http://futureos.de --> Get the revolutionary FutureOS (Update: 2022.03.09)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.12.26)


When I drop the baud rate to 2400 or 4800 the output is crystal clear but unfortunately it keeps triggering the watchdog timer which reboots the modem. So everything under 9600 baud won't work. With 9600 baud on the other hand my connection is rock solid but unfortunately the terminal seems unable to handle things properly (maybe a limitation of the CPS 8256?). Running Mex didn't make a difference there either btw.


It really does look like a catch 22: the cps 8256 struggles with 9600 baud* while the modem's ESP 8266 chip doesn't like anything below that threshold. Same terminal output @9600 and 7200 baud:

Unfortunately dropping the baud rate isn't an option as the watchdog timer eventually steps in, rebooting the modem.

*quote: "Note that the 8250 is only reliable at speeds up to 9600 baud. To use faster speeds, you should replace it with a 16550AF chip, which is pin-compatible with the 8250."

Powered by SMFPacks Menu Editor Mod