Printed Amstrad Addict magazine announced, check it out here!

Main Menu

CP/M + Borland Turbo Pascal 3: Cannot edit

Started by m_dr_m, 19:38, 27 April 23

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi! Soft, almost.

I want to try Turbo Pascal (again).
I have tried the Borland TP3 found on cpc power.

When entering edit mode, all stuff get printed without proper location (e.g. column and line numbers are display mangled with the entered character). See bottom line in screenshot:

I've tried both with CP/M in ROM and the original CPC 6128 Disk, without *any* interface connected. Same result.

@Nemo59 Did you ever encounter such issue?

I have no idea how to diagnose that, let alone fix. Any tip welcome.


Hi, please change with TINST.COM your Terminal to Zenith (30)
CPC6128, Ulifac, Z80 Assembler, Turbo Pascal, Comal-80, HP41, HP71B, HP75C



You can try this version that works too.
You don't need Amstrad System CP/M disks as you can start it directly with |CPM.

Turbo Pascal (CPM) (Terminal Zenith).zip



I can't seem to download this, my french is not very good but I think it says I am not authorised to download it


I just uploaded it to another hosting.
Can you try here: Turbo Pascal (CPM) (Terminal Zenith).zip


Thank you, this one downloaded ok.

Powered by SMFPacks Menu Editor Mod