Author Topic: blank screen Schneider CPC 664  (Read 459 times)

0 Members and 1 Guest are viewing this topic.

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 188
  • Country: scotland
    • Gee-k.net
    • Awards
blank screen Schneider CPC 664
« on: 00:22, 04 October 21 »
Hi folks. I bought a couple of Schneider CPC 664's a while back and have finally gotten round to having a look at the non working one of the two.I was following some tips on where to look for potential issues and noticed that the data input on four of the ram chips (118,119, 124 & 123) was a bit off. The peaks of the square wave is around 2.5v instead of being closer to 5v (attached image).They also aren't very square. I think this is causing no data output on the ram chips.This evening I have desoldered the chips and socketed in some replacements (unknown condition, was all I had), and the result is the same almost. Only change being that the scope is clearer (no ghoasting of a possible different signal).I've attached a couple of images of what I see on the scope for input and output of these RAM chips. I feel like the input signal looks like it's doing something but maybe grounding out somewhere (i.e. inside a chip)?Whilst I wait on some new RAM chips, can anyone else think of what might be causing this issue?


« Last Edit: 18:54, 04 October 21 by geebus »
like
1
Members reacted like:
Joseman,

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 188
  • Country: scotland
    • Gee-k.net
    • Awards
Re: blank screen Schneider CPC 664
« Reply #1 on: 18:49, 07 October 21 »
Done some more probing around and decided to socket the ROM chip to use Noel's diagnostics.
The diagnostics loaded up fine and showed the RAM as working.
SO i believe it's the ROM that's actually causing the issue in this case. Going to order some 32Kib ROM's and burn a replacement. Hopefully that works.
like
1
Members reacted like:
Joseman,

Offline Joseman

  • 6128 Plus
  • ******
  • Posts: 826
  • Country: es
    • Awards
Re: blank screen Schneider CPC 664
« Reply #2 on: 18:36, 08 October 21 »
Done some more probing around and decided to socket the ROM chip to use Noel's diagnostics.
The diagnostics loaded up fine and showed the RAM as working.
SO i believe it's the ROM that's actually causing the issue in this case. Going to order some 32Kib ROM's and burn a replacement. Hopefully that works.
Hi

You can desolder the ROM, read the content and compare with the offical roms while you wait for the news.
like
0
No reactions

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 188
  • Country: scotland
    • Gee-k.net
    • Awards
Re: blank screen Schneider CPC 664
« Reply #3 on: 17:18, 13 October 21 »
Hey, Sorry I thought I had updated this.
I have the CPC664 working now. It was indeed the ROM. I burned a new one and socketed it in. Machine now works.
I'm now hoping that the floppy drive is going to work. I've cleaned the head and renewed the belt (old one disintegrated). Just looking for the DSKtest software that I used previously for checking drive speeds.I'm not too hopeful for this drive as it's one of the ones that are prone to failing and the part that wears isn't fixable (yet).
like
0
No reactions