Printed Amstrad Addict magazine announced, check it out here!

Main Menu

"Disc missing" with some disks and not others ?

Started by reno, 17:25, 08 March 24

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



I've just sold an original game disk and the buyer tells me it won't work on his 6128 ("disc missing")
I had tested it before sending and it worked just fine on mine, and I had previously purchased it as tested and working as well.
So that's at least 2 Amstrads where the disk works !

The buyer sent me a video where he loads another original game disk just fine.
He then power cycles the CPC, inserts the disk I sold him, runs "cat" : you can hear the disk spinning, moving to track 0 and almost immediately after the "disc missing" message appears. He presses "C" to cancel, "bad command" and the disk keeps spinning for a few more seconds.

Any ideas for what might be wrong ? Head alignment ? Speed ?


it could be differences of friction between floppies, the error speaks by itself, replace the belt
My pronouns are RASM and ACE


Quote from: roudoudou on 17:59, 08 March 24it could be differences of friction between floppies, the error speaks by itself, replace the belt

So basically rotation speed is too slow with that floppy ?

I told him it was 100% the drive because the disc worked in 2 other Amstrads before, but then he tried with his external FD-1 and had the same problem, so I had to accept a return... when the disc arrives back I will measure the rotation speed in my drive compared to other discs.

It's a shame because he really wanted this game, but I guess it will be hard to convince him to replace the belts and/or adjust the speed in both of his drives. Even if that's, in fact, the real solution.

I wonder if I can do anything to reduce friction in this disk before I sell it again.


If he is serious about CPC gaming, then he already knows that belts can be an issue on these drives. I'd politely suggest to him, that he should consider replacing the belt and trying again. If he seriously "really wanted the game", then he should be prepared to change the belt in order to have it. However, it may not be the belt. It could be just that the set speed is at the lower end of the tolerances (around 290RPM) and a stiffer disk is taking it below that tolerance. Suggest also that he should use one of the available RPM testers while that disk is in the drive.


Powered by SMFPacks Menu Editor Mod