CPCWiki forum

General Category => Technical Support - General => Topic started by: Porky on 17:45, 27 November 21

Title: CP464 - keyboard not working, random noises and characters on screen
Post by: Porky on 17:45, 27 November 21
Hi All


Got a faulty CPC464, the keyboard is totally dead, there are occasional noises from the speaker and also random characters appearing on the screen.
I have powered up without the keyboard or the cassette player/speak section and still get the random characters appearing on the screen.
Am I correct in assuming the AY chip is at fault ?
Title: Re: CP464 - keyboard not working, random noises and characters on screen
Post by: Bryce on 17:22, 29 November 21
Yes, most likely a dodgy AY.

Bryce.
Title: Re: CP464 - keyboard not working, random noises and characters on screen
Post by: Amsiga on 21:53, 29 November 21
Ok so I think I've got the same issue  :(


I've just brought my 464 back to life after installing a new RAM chip, was having some issues with the fire button not working on my zipstick, so was using the multimeter to trace the feeds to the AY chip \ keyboard connector from inside the joystick, all was well.

Things started working after I checked the switch in the joystick and found nothing much wrong, so I set off to play Indiana Jones & The Temple of Doom which was working well for a good half an hour or so. I paused the game, returned some 40 minutes later to find the machine had reset and was emmiting white noise from the speaker, clicking the tape drive relay on and off and throwing junk on the screen.


Removing the keyboard the issue remains, running the diagnostic ROM it often freezes at the CRTC check, if I leave the unit off for some time to "cool down", the diagnostics will run long enough to let me get to the keyboard test page where the keys go crazy for a while before the unit freezes.


From what I've read I'm 99% sure the AY is the cause, but it bothers me that it may fail after a simple probe with a multimeter, are they this sensitive?


Title: Re: CP464 - keyboard not working, random noises and characters on screen
Post by: Amsiga on 19:49, 11 December 21
Quote from: Amsiga on 21:53, 29 November 21From what I've read I'm 99% sure the AY is the cause, but it bothers me that it may fail after a simple probe with a multimeter, are they this sensitive?
To conclude my case, it was not the AY after all but instead the M5L8255AP-5 @ IC107 which was faulty.

New socketed chip and now it's back to full working order once more :D
Powered by SMFPacks Menu Editor Mod