General Category > Technical Support

CPC 464 - very quiet speaker audio

(1/3) > >>

gw0udm:
Hi all


I've rescued what turns out be quite an an early 464 (keyswitch keyboard etc) which I've cleaned up and generally works.


However there is a problem with the audio - from the internal speaker there is a lot of noise and crackling and it's really quiet even when turned up full. However the actual sound itself is OK if you listen hard, and if I connect up external powered speakers it sounds fine.


I've had a look at the volume control and tried to spray some switch cleaner in, also remade the solder joints on the volume assembly but with no improvement.


It does load games from tape with no issue. I'm going to have a look at the speaker itself although it sounds a bit more like an amplifier / electronics type issue.


Any thoughts? I've read suggestions that this might be the AY chip at fault although if that were the case I would have thought that I'd not get proper sound at all?


Grateful for any suggestions


James



Bryce:
The capacitors in the amplifier might be failing.

Bryce.

gw0udm:
Thanks - any particular likely culprits? There are a lot of small capacitors scattered around and they look OK but obviously difficult to conclude much from that.


I'm sure it's something with the electronics, I've checked the speaker and that looks fine but I resoldered everything for good measure.


James

Bryce:
Only the electrolytic capacitors will be an issue. Have you any measurement equipment?

Bryce.

gw0udm:
Thanks


I've got a fairly basic digital multimeter but nothing else unfortunately. I probably should get something a bit more up to date.


James

Navigation

[0] Message Index

[#] Next page

Go to full version
Powered by SMFPacks Media Embedder
Powered by SMFPacks Alerts Pro Mod
Powered by SMFPacks Mentions Pro Mod