CPC464 White Screen

Started by antpant7, 12:47, 06 February 22

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

antpant7

Hello, I recently purchased a CPC464 with the MC0099a tiny motherboard. When I switch it on it get a faint garbled noise through the speaker and a white screen with zig-zag black bars across it. I tried replacing the z80 and also tried piggybacking some more ram to no avail. Does anyone have any ideas what could be wrong ?


Thanks in advance. Antony.

Animalgril987

Hi Antony.
Do you get a series of beeps if you hold the DEL  key down?




gerald

Quote from: antpant7 on 12:47, 06 February 22
Hello, I recently purchased a CPC464 with the MC0099a tiny motherboard. When I switch it on it get a faint garbled noise through the speaker and a white screen with zig-zag black bars across it. I tried replacing the z80 and also tried piggybacking some more ram to no avail. Does anyone have any ideas what could be wrong ?
Does not looks good to me.

If you have a voltmeter, can you check that you have proper 5V, then that the Z80 reset line (pin 26) is high.
If the reset stays low, then you likely have a dead pre-asic.

VincentGR

I had the same screen with a dead rom.
Don't take my word though, cause could be many other issues.

antpant7

Quote from: gerald on 13:13, 06 February 22
Does not looks good to me.

If you have a voltmeter, can you check that you have proper 5V, then that the Z80 reset line (pin 26) is high.
If the reset stays low, then you likely have a dead pre-asic.


Hello. I checked for +5v at pin 11 and Pin 26 both reading high. I do have a donor board (MC0044D) with a spare 40009 rom on it. Do you think that is worth a try ?


Thanks
Antony Myers.

Powered by SMFPacks Menu Editor Mod