Author Topic: EME-150A Disc missing  (Read 395 times)

0 Members and 1 Guest are viewing this topic.

Offline angelcaio

  • CPC664
  • ***
  • Posts: 130
  • Country: es
  • AMSTRAD CPC-464
  • Liked: 42
  • Likes Given: 44
EME-150A Disc missing
« on: 17:56, 19 March 20 »
I have a problem with an EME-150A
It said "disc missing" on every disk access with a horrible noise.
I have opened it and the belt looked like it was a filthy mass. I have cleaned the remains with alcohol and put a new one.
No longer making noise, just normal noise on a floppy drive, but still giving "disc missing" error
That could be happening?

Thanks in advance

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.602
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4148
  • Likes Given: 433
Re: EME-150A Disc missing
« Reply #1 on: 19:15, 19 March 20 »
Either the head motor has given up (quite common on the 150 and unfortunately non-repairable) or it needs to be calibrated or it has dry joints or....
Many things can go wrong with these, hard to say without seeing it.

Bryce.

Offline GUNHED

  • 6128 Plus
  • ******
  • Posts: 1.862
  • Country: de
  • Reincarnation of TFM
    • FutureOS - The quickest OS for the CPC and Plus
  • Liked: 840
  • Likes Given: 2093
Re: EME-150A Disc missing
« Reply #2 on: 19:25, 19 March 20 »
Ist the pin still there?
http://futureos.de --> Get the revolutionary FutureOS (Recent update: 2019.08.07)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2019.08.14)

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.602
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4148
  • Likes Given: 433
Re: EME-150A Disc missing
« Reply #3 on: 20:24, 19 March 20 »
A missing pin gives a write-protect error. Disk missing errors come from the ready signal not being set.

Bryce.

Offline angelcaio

  • CPC664
  • ***
  • Posts: 130
  • Country: es
  • AMSTRAD CPC-464
  • Liked: 42
  • Likes Given: 44
Re: EME-150A Disc missing
« Reply #4 on: 13:53, 21 March 20 »

I opened the floppy drive again. I turned the pulley several times with my finger and it screeched. I lubricated it with a bit of WD40 until it stopped squeaking and reassembled everything.
Now it reads, writes, and displays the directory, though only with certain disks.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.602
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4148
  • Likes Given: 433
Re: EME-150A Disc missing
« Reply #5 on: 14:16, 21 March 20 »
The other disks may just be bad?

Bryce.

Offline angelcaio

  • CPC664
  • ***
  • Posts: 130
  • Country: es
  • AMSTRAD CPC-464
  • Liked: 42
  • Likes Given: 44
Re: EME-150A Disc missing
« Reply #6 on: 16:03, 21 March 20 »
The floppys are from a lot I bought on ebay two years ago. Hardly two or three worked and the rest "repaired" marking the bad tracks with tbh disc repair. So they are not very reliable ...
I'll test the floppiys on 6128 when I have access to it

Offline tjohnson

  • Supporter
  • 6128 Plus
  • *
  • Posts: 817
  • Country: gb
    • index.php?action=treasury
  • Liked: 239
  • Likes Given: 204
Re: EME-150A Disc missing
« Reply #7 on: 16:16, 21 March 20 »
Have you run the rpm program on it to check the rotation speed?  Should be 300rpm

Offline angelcaio

  • CPC664
  • ***
  • Posts: 130
  • Country: es
  • AMSTRAD CPC-464
  • Liked: 42
  • Likes Given: 44
Re: EME-150A Disc missing
« Reply #8 on: 17:37, 21 March 20 »
Have you run the rpm program on it to check the rotation speed?  Should be 300rpm
yes. returns values ​​between 299.26 and 299.34