Faulty 464

Started by Dagger, 01:02, 07 May 16

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Dagger

I picked up a 464 of the bay and as half expected it turned out to be faulty as not used in over 10 years  :( . It powers on, the tape deck seems to work but all I get it a purple(Mouve) screen. Any advice please
Life's a bitch. You marry one or two then you die !

Zoe Robinson

Sounds like it needs a clean inside, in the first instance. That can clear up a surprising number of video problems.

Dagger

What do I clean ? I removed the ULA chip and the Z80 and re-seated them
Life's a bitch. You marry one or two then you die !

Audronic

@Dagger

If you press the del key several times does the computer beep (loudspeaker)

Good luck

Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Dagger

Hi, There is no sound from pressing the del key(kept pressing for a couple of mins, nothing). Put my other monitor on as I remembered the colours where never right on the first one and now it comes up with a light blue screen. Still blank not logo or anything
Life's a bitch. You marry one or two then you die !

Audronic

@dagger


Ok.
How technical are you ?.
Do you have a probe, CRO, Multimeter etc.
What country do you live in ?


Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Dagger

I have a couple of meters(fluke) a soldering iron and that's about it, UK
Life's a bitch. You marry one or two then you die !

Audronic

#7
@Dagger


1)  Does the Power light come on
2)  Grab a Schematic from the Wiki  and some Board layouts "   Schematics - CPCWiki  "
  or  "   documentations:repository [Grimware]  ""
3) Measure the +5 Volts inside the machine.
3a) Purchase a Probe (Probably under 10 Eng Pounds)
4) Have a look inside the machine for any obvious damage.
5) Get some help locally.


Good luck      Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Dagger

#8
Hi, Yes it has power it gives a blank light blue blank screen as mentioned.
   Love the quote "Get help locally". Nobody I know or work with etc as ever heard of an Amstrad computer :) The people I have spoke with look at you with a puzzled or blank look on their face like you are from another planet :)
   I have a spare working 464 would swaping the chips to test risk any damage to the working ones?



Life's a bitch. You marry one or two then you die !

CraigsBar

Where are you @Dagger? Most issues are fixable. And @Bryce has probably seen most of them before!
IRC:  #Retro4All on Freenode

Dagger

Hi, I am East of London, UK.
Life's a bitch. You marry one or two then you die !

Audronic

@Dagger


Yes you could swap the Z80 That is in a socket, i am not sure what else is.
Have a look at the board and see what is in sockets on both boards (Please put a label on the ones from the good 464 before swapping).


I can not help you "" Locally "" as i am upside down here in Australia.  :)
There are a lot of members from the UK on this board and i am sure that somebody will live nearby with some technical skills..


Good Luck   Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

||C|-|E||

I was there during the morning collecting a CTM 644 (thanks again! It was very nice to meet you  :D ) and I had a little look at the computer. There is nothing obviously wrong just looking at the board by eye. I can help and replace any chip for a new one, the problem is that we need a proper diagnose to know what to replace  :-X

Bryce

Does the start screen have a border or is it all one colour? Culprit No. 1 is RAM, then Z80, then CRTC.

Bryce.

Dagger

It has a black border. Is ram a common failure on these machines?
Life's a bitch. You marry one or two then you die !

Bryce

Then the Z80 is fine and the CRTC is most likely ok too. RAM issue. Yes, RAM on almost every retro computer is an issue.

Bryce.

Powered by SMFPacks Menu Editor Mod