CPCWiki forum

General Category => Technical Support => Topic started by: angelcaio on 17:45, 17 August 21

Title: Mfp920 mod
Post by: angelcaio on 17:45, 17 August 21
About seven years ago I bought the Sellmyretro a zaxon clone ddi-1 and a modified sony mfp920 disk drive which has been working until now. [/font]
For a couple of months it has started to fail, first as stops when showing the contents of the directory both with the basic command |dir and CP/M.[/font]
Now it doesn't work anymore and when trying to access it, it takes a few seconds and shows the message "bad command"[/font]
I have modified another unit, also Sony mfp920, cutting track 34 and connecting with a cable this track 34 and the density sensor of the unit (I cover the high-density hole of the floppy disks with adhesive tape) following a tutorial.[/font]
The unit works perfectly, it detects when there is no disk in the unit showing "disk missing" but the unit remains with the activity led permanently on, which was not the case with the first unit purchased from Piort.[/font]
I have opened that first unit and I have seen that it does not have the trace cut to pin 34 and this pin is attached with a wire to a point in the center of the board that I have tried to follow and I think it is connected to the density sensor (I do not have now a multimeter on hand to check) and I don't see any other change.[/font]
I attach a photograph[/font]
Does anyone see any other modifications on the photo?[/font]
Thanks in advance.[/font]



https://postimg.cc/gallery/r5fqGpV[/font]
Title: Re: Mfp920 mod
Post by: eto on 14:29, 18 August 21
Is that documented somewhere what it actually does?
Title: Re: Mfp920 mod
Post by: Audronic on 16:05, 18 August 21
Just cut the track above pin 34
This is the Modification I use for the Sony drives.
If it is still Faulty then the drive is unwell
Good Luck


Keep Safe


Ray