Author Topic: CPC 664 sound problems  (Read 2338 times)

0 Members and 2 Guests are viewing this topic.

Offline Fer

  • CPC464
  • **
  • Posts: 6
  • Country: gb
  • Liked: 1
  • Likes Given: 0
CPC 664 sound problems
« on: 10:38, 04 June 17 »
Hi there,


I have a lovely 664 that has the 'white noise' sound problem.  I see that this has been covered before and replacement of the AY chip is recommended.


Am I right in thinking that is has to be a specific model, not the 'A' version that you get in the Spectrums?


I'm struggling to find a replacement, so does anyone know of a good source?  Also, as my soldering is terrible, does anyone on here provide a service for this kind a work?


Thanks all, great site :)

Offline VincentGR

  • 6128 Plus
  • ******
  • Posts: 1.400
  • Country: gr
    • Parts from the past.
  • Liked: 897
  • Likes Given: 2091
Re: CPC 664 sound problems
« Reply #1 on: 21:57, 05 June 17 »
Is white noise permanent?
Visit my BBS (Telnet) : flashbackbbs.sytes.net:6502
http://loaderror.eu/
Amiga 1200 Black Project

Offline arnoldemu

  • Supporter
  • 6128 Plus
  • *
  • Posts: 5.336
  • Country: gb
    • Unofficial Amstrad WWW Resource
  • Liked: 2281
  • Likes Given: 3478
Re: CPC 664 sound problems
« Reply #2 on: 22:22, 05 June 17 »
internal speaker only or also on stereo sound output?

If it's only speaker then that may be broken.
My games. My Games
My website with coding examples: Unofficial Amstrad WWW Resource

Offline Fer

  • CPC464
  • **
  • Posts: 6
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: CPC 664 sound problems
« Reply #3 on: 14:45, 06 June 17 »
Thanks for the replies :)


It tends to play white noise instead of the usual square wave noises, but not always.  Some game tunes sound more like quiet popping sounds instead.


The delete beep is white noise.


Tried through headphones, but it's the same I'm afraid ...

Online Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.441
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4712
  • Likes Given: 488
Re: CPC 664 sound problems
« Reply #4 on: 15:05, 06 June 17 »
Hi Fer,
    that definitely sounds (no pun intended) like your AY is faulty. Luckily they are readily and cheaply available. Remove the old one, install a socket and replace the AY.

Bryce.

Offline VincentGR

  • 6128 Plus
  • ******
  • Posts: 1.400
  • Country: gr
    • Parts from the past.
  • Liked: 897
  • Likes Given: 2091
Re: CPC 664 sound problems
« Reply #5 on: 15:38, 06 June 17 »
I have an issue with white noise too and I did a post for that.
I replaced my AY but there no results, mine does that on my 6128 while loading 128k games  :picard:
Visit my BBS (Telnet) : flashbackbbs.sytes.net:6502
http://loaderror.eu/
Amiga 1200 Black Project

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.458
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 322
  • Likes Given: 748
Re: CPC 664 sound problems
« Reply #6 on: 15:47, 06 June 17 »
@Fer


Does the volume control alter the volume of the white Noise ?


Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline Fer

  • CPC464
  • **
  • Posts: 6
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: CPC 664 sound problems
« Reply #7 on: 17:25, 06 June 17 »
Hi, yes the volume control does alter the volume.  It's as if everything is normal except the computer is playing the wrong sounds.

Offline Fer

  • CPC464
  • **
  • Posts: 6
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: CPC 664 sound problems
« Reply #8 on: 17:36, 06 June 17 »
It sounds like a very similar problem to this ..
Not sure they managed to fix it or not


http://www.cpcwiki.eu/forum/hardware-related/cpc-6128-sound-problems/


Thanks again all :)

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.458
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 322
  • Likes Given: 748
Re: CPC 664 sound problems
« Reply #9 on: 01:59, 07 June 17 »
@Fer


I could not find a Circuit of the Sound/Tape for the 664 BUT i have a circuit for a 6128.
I hope that this is the same.
Just short out the sound input at the point shown with a 10 Microfarad capacitor to ground an see if the noise goes away.
 if it does not then the following Amplifier requires replacement ?
Good luck


Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline Fer

  • CPC464
  • **
  • Posts: 6
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: CPC 664 sound problems
« Reply #10 on: 09:41, 08 June 17 »
Thanks for that Audronic,  I'll get someone better than me with electronics to have a look :)

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
  • Liked: 111
  • Likes Given: 95
Re: CPC 664 sound problems
« Reply #11 on: 21:46, 08 August 17 »
I'm in UK and can have a look at that for you mate

Offline Fer

  • CPC464
  • **
  • Posts: 6
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: CPC 664 sound problems
« Reply #12 on: 21:42, 15 August 17 »
Thanks mate.  I've been rather busy and only got as far as getting a NOS chip.  I may take you up on that offer if still possible in a couple of weeks :)