Problem with a cpc

Started by talrek, 16:53, 23 May 21

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

talrek

First of all : Hello everybody, it's been a really long time since I came due to personal problems...
I almost didn't touch any CPC since 2 years....
Now that  have more personal time I decided to came back, and to begin, I put in my mind to restore a cpc 6128.


So someone gave me a faulty cpc... and after  opening it, I understood why  :picard:
I think the previous owner tried to replace the Amsdos rom, by another eprom. But just pulled it at Some point without desoldering it properly. Then he tried to wire the missing lines...
It gives that :



76-D4-B328-5619-42-CA-B0-E1-F58-A92293-EB4" border="0

I checked everything and it seems fine.
But when powering the cpc on my ctm644, the image doesn't stop scrolling as if there was a frequency problem...
Here is the video : [size=78%]https://youtube.com/shorts/GnoenXlKANU?feature=share[/size]


Do you have any idea what the problem could be ?


Thank you all !!!!


Bryce

Dodgy ground on the monitor socket.

Bryce.

talrek

So simple I even didn't think about it  :o
Thank you Bryce always here when help is needed 👍


I'll try it

Bryce

Check the joints under the Monitor socket, they often get cracks.

Bryce.

talrek

Hi,
I checked the monitor socket. No problem with it, I tested with a multimeter no continuity problem...

Bryce

Try reseating the Gate Array. Also check the solder joints on the CRTC, particularly pins 39 and 40.

Bryce.

talrek

Hi,
It didn't solve the problem. I resoldered the crt to be sure...




Bryce

Have you cleaned the contacts on the monitor DIN plug and socket? Have you tried adjusting V-Hold?

Bryce.

gerald

Looking at the video, I am not convinced that we have connector issue.
Horizontal sync looks perfect, only vertical one is suspicious and could be a side effect of a ROM replacement dodgy work.
I can have a look at it if you want.

talrek

I checked the monitor and main board plug. No problem with it.
Monitor works well with another cpc.
By v-hold you mean behind the monitor ? Yes I tried, and I can adjust the image, it seems stable but with a border...


May be a rom issue, as I said the previous owner tried to replace the 40015, and he makes some damages on the board (the traces) so he put some wires to correct it (you can see the picture) I think it could be related... somehow... even if it seems right to me, I could have missed something...

Bryce

Then check all the data and address lines, that none of them are open.

Bryce.

Powered by SMFPacks Menu Editor Mod