Author Topic: Problem with M4 and Wifi  (Read 519 times)

0 Members and 1 Guest are viewing this topic.

Offline jaimebueno

  • CPC464
  • **
  • Posts: 3
  • Country: es
  • Liked: 0
  • Likes Given: 1
Problem with M4 and Wifi
« on: 18:33, 03 February 21 »
Hi, lately I am having some trouble browsing the M4 directories over wifi.  Sometimes I enter a folder and it returns me to the root of the micro sd, other times it takes a long time and the browser ends up giving an error, I do a Netstat and it returns Idle status and I have to restart the M4.  This problem is only accessing via wifi, using any frontend I can move without problems.  Before I had no problem using wifi ...


Thanks.

Offline chinnyhill10

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.395
  • Country: 00
    • https://www.youtube.com/user/chinnyhill10
  • Liked: 771
  • Likes Given: 522
Re: Problem with M4 and Wifi
« Reply #1 on: 19:43, 03 February 21 »
Hi, lately I am having some trouble browsing the M4 directories over wifi.  Sometimes I enter a folder and it returns me to the root of the micro sd, other times it takes a long time and the browser ends up giving an error, I do a Netstat and it returns Idle status and I have to restart the M4.  This problem is only accessing via wifi, using any frontend I can move without problems.  Before I had no problem using wifi ...


Thanks.


Is the signal strong enough? I ended up adding an access point in the room the CPC is in mainly for the M4. While my phone and laptop were generally OK, the M4 would often struggle and you could hear it hunting for wifi if you turned the CPC's volume control up. Going forward, perhaps the M4 needs a better aerial configuration.
--
ChinnyVision - Reviews Of Classic Games Using Original Hardware
chinnyhill10 - YouTube

Offline jaimebueno

  • CPC464
  • **
  • Posts: 3
  • Country: es
  • Liked: 0
  • Likes Given: 1
Re: Problem with M4 and Wifi
« Reply #2 on: 20:36, 03 February 21 »
Yes the signal is good. I have the router and the cpc at the same room.


At this moment Netstat gives me 0xBA in signal.

Offline GUNHED

  • 6128 Plus
  • ******
  • Posts: 2.681
  • Country: de
  • Reincarnation of TFM
    • FutureOS - The quickest OS for the CPC and Plus
  • Liked: 1260
  • Likes Given: 2954
Re: Problem with M4 and Wifi
« Reply #3 on: 23:29, 22 June 21 »
By accident I did switch the M4 ROM off in the menu.


Now, how can I switch it on again?


Please help.
http://futureos.de --> Get the revolutionary FutureOS (Update: 2021.01.24)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.07.15)

Offline SkulleateR

  • 464 Plus
  • *****
  • Posts: 384
  • Country: de
  • Liked: 203
  • Likes Given: 109
Re: Problem with M4 and Wifi
« Reply #4 on: 23:47, 22 June 21 »
|M4ROMOFF should only resist until next powecycle ...

Offline GUNHED

  • 6128 Plus
  • ******
  • Posts: 2.681
  • Country: de
  • Reincarnation of TFM
    • FutureOS - The quickest OS for the CPC and Plus
  • Liked: 1260
  • Likes Given: 2954
Re: Problem with M4 and Wifi
« Reply #5 on: 23:48, 22 June 21 »
|M4ROMOFF should only resist until next powecycle ...
I used the web menu. Any idea?
http://futureos.de --> Get the revolutionary FutureOS (Update: 2021.01.24)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.07.15)

Offline SkulleateR

  • 464 Plus
  • *****
  • Posts: 384
  • Country: de
  • Liked: 203
  • Likes Given: 109
Re: Problem with M4 and Wifi
« Reply #6 on: 23:59, 22 June 21 »
Should be the same, Power Cycle the machine ! Or what did you do on the web interface ? took out the check at ENABLED on ROMS ?

Offline GUNHED

  • 6128 Plus
  • ******
  • Posts: 2.681
  • Country: de
  • Reincarnation of TFM
    • FutureOS - The quickest OS for the CPC and Plus
  • Liked: 1260
  • Likes Given: 2954
Re: Problem with M4 and Wifi
« Reply #7 on: 00:01, 23 June 21 »
Should be the same, Power Cycle the machine ! Or what did you do on the web interface ? took out the check at ENABLED on ROMS ?


Yes, I took out the upper hook in the ROMs menu.
Now I can't access the M4 any longer using the PC Web interface.
http://futureos.de --> Get the revolutionary FutureOS (Update: 2021.01.24)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.07.15)

Offline GUNHED

  • 6128 Plus
  • ******
  • Posts: 2.681
  • Country: de
  • Reincarnation of TFM
    • FutureOS - The quickest OS for the CPC and Plus
  • Liked: 1260
  • Likes Given: 2954
Re: Problem with M4 and Wifi
« Reply #8 on: 00:07, 23 June 21 »
Solution found: Yes, the web interface still works. Must have had a weak network for quite some time.
Thanks for your help.  :) :) :)


However: Deleting the hook from "Enabled" does not really disable the ROMs.  :-\
http://futureos.de --> Get the revolutionary FutureOS (Update: 2021.01.24)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.07.15)

Offline SkulleateR

  • 464 Plus
  • *****
  • Posts: 384
  • Country: de
  • Liked: 203
  • Likes Given: 109
Re: Problem with M4 and Wifi
« Reply #9 on: 00:09, 23 June 21 »
Ok, but using the M4 RESET button also works (just wanted to mention that) ;)

Offline GUNHED

  • 6128 Plus
  • ******
  • Posts: 2.681
  • Country: de
  • Reincarnation of TFM
    • FutureOS - The quickest OS for the CPC and Plus
  • Liked: 1260
  • Likes Given: 2954
Re: Problem with M4 and Wifi
« Reply #10 on: 00:24, 23 June 21 »
Ok, but using the M4 RESET button also works (just wanted to mention that) ;)
Not if you switch the ROMs off in the Web interface, tried it couple of times. M4ROM stays off, the others are on again. Need to look at it again tomorrow.
http://futureos.de --> Get the revolutionary FutureOS (Update: 2021.01.24)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.07.15)