General Category > Technical Support

Strange CPC 6128 /drive behaviour

(1/3) > >>

Hi all,

I have some trouble with a 6128: I change the drive belt of the drive and then run "RPM" soft and DSK test to calibrate the rotation speed. Both software don't report me the speed (no info, drive is running endlessly). I have tested the drive on an other CPC and it works (RPM show 302RPM which is acceptable).

So the issue is coming from the motherboard; I already check and reflow all welding point in the area of the FDC but no progress).
Any idea is welcome.

Thank you

Either a broken connection on the flat cable or one or more of the driver IC's has failed.


I will change the flat cable to be sure.

EDIT: new flat cable installed: same result.

I tried a 3rd drive and it give the same result on this motherboard.

The it's the driver IC's.


Which ones do you mean ?


[0] Message Index

[#] Next page

Go to full version
Powered by SMFPacks Media Embedder
Powered by SMFPacks Alerts Pro Mod
Powered by SMFPacks Mentions Pro Mod