CPCWiki forum

General Category => Technical Support - General => Topic started by: rolandahoy on 13:29, 05 August 21

Title: Tech support urgently needed, please :-( CPC and M4!
Post by: rolandahoy on 13:29, 05 August 21
To someone with CPC tech insights..

Tried to resurrect a CPC464 (tall keys) and expand it with the M4 device (with the classic edge connector)  at the same time... I was probably to eager, and connected the M4 device upside down  :picard: !

Now the CPC seems completely dead, is it fried? Can this problem be corrected? Eg. replacing some components!

Hopefully the CPC is not beyond repair!! :'(

Greetings from Rolandahoy!
Title: Re: Tech support urgently needed, please :-( CPC and M4!
Post by: Duke on 20:07, 05 August 21
How does it behave now when you turn it on without the M4 ?
The LED comes on? - It shows something on screen ?
Did you use an Amstrad Monitor as power source?

Quote from: rolandahoy on 13:29, 05 August 21
To someone with CPC tech insights..

Tried to resurrect a CPC464 (tall keys) and expand it with the M4 device (with the classic edge connector)  at the same time... I was probably to eager, and connected the M4 device upside down  :picard: !

Now the CPC seems completely dead, is it fried? Can this problem be corrected? Eg. replacing some components!

Hopefully the CPC is not beyond repair!! :'(

Greetings from Rolandahoy!
Title: Re: Tech support urgently needed, please :-( CPC and M4!
Post by: rolandahoy on 00:36, 06 August 21
Hi Duke

The CPC is current completely off, even no light in the power LED, which worries me!

First I used an external psu, with the Voltage and Amp specified in the wiki, the CPC worked (video out to TV via scart) - well some static in the loudspeaker - but what to expect after ages in a basement, even loaded some old tapes...
Then I tried to connect the M4, but apparently I was to eager and first turned the wrong side up!  :doh:
The CPC failed to switch back on ....

I assumed it may be the power supply - but after trying an old Amstrad green screen - still nothing happens!  :blank:
What happend - hope you can advise...
Greeting from Rolandahoy.


Quote from: Duke on 20:07, 05 August 21How does it behave now when you turn it on without the M4 ?
The LED comes on? - It shows something on screen ?
Did you use an Amstrad Monitor as power source?
Title: Re: Tech support urgently needed, please :-( CPC and M4!
Post by: Duke on 07:49, 06 August 21
Maybe it's just a coincidence. I would check is that the on/off switch is working, it's rather common that these fail.
Obviously you should inspect the PCB for any visible damage first.

Quote from: rolandahoy on 00:36, 06 August 21
Hi Duke

The CPC is current completely off, even no light in the power LED, which worries me!

First I used an external psu, with the Voltage and Amp specified in the wiki, the CPC worked (video out to TV via scart) - well some static in the loudspeaker - but what to expect after ages in a basement, even loaded some old tapes...
Then I tried to connect the M4, but apparently I was to eager and first turned the wrong side up!  :doh:
The CPC failed to switch back on ....

I assumed it may be the power supply - but after trying an old Amstrad green screen - still nothing happens!  :blank:
What happend - hope you can advise...
Greeting from Rolandahoy.
Title: Re: Tech support urgently needed, please :-( CPC and M4!
Post by: eto on 08:47, 06 August 21
Quote from: rolandahoy on 13:29, 05 August 21Hopefully the CPC is not beyond repair!!

Unlikely. The CPC is hard to break completely.

Check out Noels retro lab for a few videos on identifying issues with the CPC:
https://www.youtube.com/watch?v=KlPtOe4youc&list=PLmbYPqkyiASzW4qc1NOZCIBwb82tjtz_e

Maybe this helps to get a bit of a clearer picture what is wrong with your CPC, then people can probably better help tracking the issue down and how to repair it.

And as Duke said: check the power switch first. It's such a common issue and so easy to fix: https://www.cpcwiki.eu/forum/amstrad-cpc-hardware/fixing-the-power-switch/
Title: Re: Tech support urgently needed, please :-( CPC and M4!
Post by: rolandahoy on 10:00, 10 August 21
Success!!!!

My CPC464 is restored to its former glory!

It was the power-switch  :P
Now its time to explore the wonderful M4!
Such a friendly forum

Greetings from
Rolandahoy
... greetings and thanks goes to
@duke and @eto (https://www.cpcwiki.eu/forum/index.php?action=profile;u=3625)
Powered by SMFPacks Menu Editor Mod