Author Topic: 464 Plus with blank screen  (Read 175 times)

0 Members and 1 Guest are viewing this topic.

Offline Overkill

  • CPC664
  • ***
  • Posts: 93
  • Liked: 8
  • Likes Given: 6
464 Plus with blank screen
« on: 15:25, 28 September 20 »
Hi all


I have a 464 Plus with a blank screen, I removed the RAM and found one chip to be faulty, but after replacing both RAM chips I still get a blank screen :(

The screen is green with those black thin lines, all the way down the left hand side of the screen.


I have 5v on the RAM and I also have a clock on pin 6 of the Z80.  I have tested and replaced the Z80, and nothing seems to be getting overly hot.


Is it worth me removing and testing IC116 (74SL27), or any other likely candidate, before righting it off as a bad IC101?



Online Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.795
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4247
  • Likes Given: 446
Re: 464 Plus with blank screen
« Reply #1 on: 15:59, 28 September 20 »
IC116 should be a 74HCT02, not a 74LS27. Has someone changed this previously?

Bryce.

Offline Overkill

  • CPC664
  • ***
  • Posts: 93
  • Liked: 8
  • Likes Given: 6
Re: 464 Plus with blank screen
« Reply #2 on: 16:34, 28 September 20 »
Thanks for the reply Bryce.

I purchased this machine as untested, and of course it didn't work   :doh:

It looks like some boards use these 74SL27, as I have other boards that also have them.  It looks factory soldered.

Online Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.795
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4247
  • Likes Given: 446
Re: 464 Plus with blank screen
« Reply #3 on: 17:14, 28 September 20 »
Ok. And have you reason to believe the 74LS74 is faulty? Have you tested it?

Bryce.

Offline Overkill

  • CPC664
  • ***
  • Posts: 93
  • Liked: 8
  • Likes Given: 6
Re: 464 Plus with blank screen
« Reply #4 on: 17:30, 28 September 20 »
I'm not sure how to do a basic test without removing it from the board.  Can I just do a multimeter diode test between pins?

Offline Overkill

  • CPC664
  • ***
  • Posts: 93
  • Liked: 8
  • Likes Given: 6
Re: 464 Plus with blank screen
« Reply #5 on: 17:36, 28 September 20 »
I do seem to have a dead short between pins 1 and 2, when tested in the board.

Offline Overkill

  • CPC664
  • ***
  • Posts: 93
  • Liked: 8
  • Likes Given: 6
Re: 464 Plus with blank screen
« Reply #6 on: 17:38, 28 September 20 »
nah, I tested a working machine and that also has a short between pins 1 and 2 :(

Offline Overkill

  • CPC664
  • ***
  • Posts: 93
  • Liked: 8
  • Likes Given: 6
Re: 464 Plus with blank screen
« Reply #7 on: 12:01, 29 September 20 »
Could the AY cause this?

Online Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.795
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4247
  • Likes Given: 446
Re: 464 Plus with blank screen
« Reply #8 on: 13:20, 29 September 20 »
Could the AY cause this?

Possibly, but then it would be rather hot.

Bryce.