Author Topic: Sudden problem with 3" drive  (Read 1326 times)

0 Members and 1 Guest are viewing this topic.

Offline vasilisk

  • CPC664
  • ***
  • Posts: 119
  • Country: gr
  • CPC6128
  • Liked: 34
  • Likes Given: 190
Re: Sudden problem with 3" drive
« Reply #25 on: 09:31, 19 February 21 »
Yes, although they rarely fail so probably not worth it.


it seems that we are in the "rarely" case  8)

Offline vasilisk

  • CPC664
  • ***
  • Posts: 119
  • Country: gr
  • CPC6128
  • Liked: 34
  • Likes Given: 190
Re: Sudden problem with 3" drive
« Reply #26 on: 16:30, 20 February 21 »
When the cpc is on (standby), what voltage these cables must have?
« Last Edit: 21:31, 20 February 21 by vasilisk »

Offline tjohnson

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.009
  • Country: gb
    • index.php?action=treasury
  • Liked: 323
  • Likes Given: 290
Re: Sudden problem with 3" drive
« Reply #27 on: 16:50, 20 February 21 »
One provides 5v and one 12v.  The 12v is the motor and the 5v is the logic, they are reversed from a normal PC floppy drive connector, I believe the red is 12v and orange is 5v.

Offline vasilisk

  • CPC664
  • ***
  • Posts: 119
  • Country: gr
  • CPC6128
  • Liked: 34
  • Likes Given: 190
Re: Sudden problem with 3" drive
« Reply #28 on: 18:47, 20 February 21 »
Unless I'm doing something wrong, I am not getting 12 volts on the red cable. Orange cable is at 5 volt.

Offline tjohnson

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.009
  • Country: gb
    • index.php?action=treasury
  • Liked: 323
  • Likes Given: 290
Re: Sudden problem with 3" drive
« Reply #29 on: 23:18, 20 February 21 »
Does the motor spin up?


I assume this is a 6128 and is connected to an original Monitor that is providing 12v and 5v, these are separate, the 12v is via a cable from the computer plugged until the monitor  and the 5v is via a cable from the monitor plugged into the computer.


Check your Monitor is providing 12v, it's centre negative from what I recall.

Offline tjohnson

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.009
  • Country: gb
    • index.php?action=treasury
  • Liked: 323
  • Likes Given: 290
Re: Sudden problem with 3" drive
« Reply #30 on: 01:06, 26 February 21 »
@vasilisk did you fix it?