Author Topic: Keyboard problem in my Plus.  (Read 1448 times)

0 Members and 1 Guest are viewing this topic.

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Keyboard problem in my Plus.
« on: 22:25, 26 February 16 »
Hello guys!

I have a problem with my 6128 and I was thinking that maybe you could help :). It turns out that today I found that some keys were not working properly anymore. In particular, I am talking about the arrow keys and the G. So, I opened the computer and unplugged the keyboard. I plugged it back and I found that the arrows were working, but not the G. I repeated the procedure but it did not help, so I opened the keyboard and I took the membrane outside. Touching it with the finger, I see that I still have the same problem. Any suggestion? I do not see any obvious track that is cut or any other problem inspecting it by eye, and it was working fine until now... it seems that I mainly have the problem with the G, that just refuses to work  :picard:

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #1 on: 22:41, 26 February 16 »
OK, some news, all the keys are working now, but I had to disconnect all the boards from the computer and try again... do you thing that they could have something to do?

At least I am happy that the motherboard seems to be OK!

Offline gerald

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.435
  • Liked: 1006
  • Likes Given: 251
Re: Keyboard problem in my Plus.
« Reply #2 on: 22:43, 26 February 16 »
Hello guys!

I have a problem with my 6128 and I was thinking that maybe you could help :) . It turns out that today I found that some keys were not working properly anymore. In particular, I am talking about the arrow keys and the G. So, I opened the computer and unplugged the keyboard. I plugged it back and I found that the arrows were working, but not the G. I repeated the procedure but it did not help, so I opened the keyboard and I took the membrane outside. Touching it with the finger, I see that I still have the same problem. Any suggestion? I do not see any obvious track that is cut or any other problem inspecting it by eye, and it was working fine until now... it seems that I mainly have the problem with the G, that just refuses to work  :picard:
That damn G-spot  :picard:





More seriously, plus membrane are known to fail more often than needed. Maybe its time to get a new one ...
Symptoms usually start with DEL, arrows/Enter/f9/f6/f6/f.

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #3 on: 22:50, 26 February 16 »
Thank you! I will buy one then... could you recommend me a supplier Gerald? :) I could also try to buy a complete NOS keyboard, if I find one.

Actually... now that I think about it, initially there was a failure in the arrows and some f keys... like f8, f5, f2...
« Last Edit: 22:52, 26 February 16 by ||C|-|E|| »

Offline gerald

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.435
  • Liked: 1006
  • Likes Given: 251
Re: Keyboard problem in my Plus.
« Reply #4 on: 23:53, 26 February 16 »
Thank you! I will buy one then... could you recommend me a supplier Gerald? :) I could also try to buy a complete NOS keyboard, if I find one.

Actually... now that I think about it, initially there was a failure in the arrows and some f keys... like f8, f5, f2...
Well, the only place named for having Plus membrane is TRADE IN POST

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #5 on: 00:07, 27 February 16 »
Then is fine! I already sent a mail to him!  :)

Yup... is definitely the membrane. When I put the keyboard back, sometimes does not work properly, then I move the membrane a little bit just in the area that is close to the insertion in the motherboard and it works again. However, when I release and the membrane goes back to the previous position it does not work. Maybe I could try with a little bit of that conductive silver paste... huum... another option would be to try with a pencil eraser in the silver, just in case is a layer of oxide and the track is fine.

P.D: at the end, instead of with a pencil eraser I just tried "sanding" very carefully the connectors to the motherboard with toothpaste and it did the trick, it works well now, although I am ordering a new membrane, because this is not going to last  :-X . I will try to repair this one with conductive paste, though.
« Last Edit: 01:15, 27 February 16 by ||C|-|E|| »

Offline ukmarkh

  • 6128 Plus
  • ******
  • Posts: 1.417
  • Country: england
    • Classic Replay
  • Liked: 301
  • Likes Given: 75
Re: Keyboard problem in my Plus.
« Reply #6 on: 01:27, 27 February 16 »
I was gonna say, treat the contacts, It's not just Amstrads, lots of computers are terrible for this...


Sent from my iPhone using Tapatalk

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #7 on: 01:33, 27 February 16 »
Yup, but it did not last, as expected. I will try tomorrow with some conductive silver paint. Maybe I will be able to repair it while I wait for the replacement...  :-X

Offline PulkoMandy

  • 464 Plus
  • *****
  • Posts: 338
  • Country: fr
  • Liked: 269
  • Likes Given: 1
Re: Keyboard problem in my Plus.
« Reply #8 on: 09:41, 27 February 16 »
I have heard that in some weather conditions, the classic CPC connector for the membrane works better than the Plus one (cost reduction went a bit too far there it seems). So maybe replace the connectors on the motherboard with ones from a classic CPC, or a new replacement if someone has a reference?

Offline Kris

  • 6128 Plus
  • ******
  • Posts: 554
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 819
Re: Keyboard problem in my Plus.
« Reply #9 on: 11:18, 27 February 16 »
I already fixed some similar issue by cutting 0.5mm at the end of membrane, cleaned the connector as well with a "special contact" product.


Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #10 on: 12:59, 27 February 16 »
At some point it would be nice to do something more permanent to our keyboards, like either a proper PS2 adapter or a substitution for a compatible mechanical one (although this would be quite expensive). Another option would be to try to produce new good quality membranes, Spectrum people already have them :)

Offline gerald

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.435
  • Liked: 1006
  • Likes Given: 251
Re: Keyboard problem in my Plus.
« Reply #11 on: 13:20, 27 February 16 »
At some point it would be nice to do something more permanent to our keyboards, like either a proper PS2 adapter or a substitution for a compatible mechanical one (although this would be quite expensive). Another option would be to try to produce new good quality membranes, Spectrum people already have them :)
PS2 : i've got one  ;) , but I do not consider it as a proper replacement, or you will need to add sticker to the key so it match the original CPC layout. My current solution involve translating PS2 mapping to CPC mapping and have some limitation.
Mechanical : why not, but this will be expensive.
New membrane : as soon as there is a market -> Keyboard Membranes

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #12 on: 14:00, 27 February 16 »
In my case, I would go for a mechanical solution all the way, and I am ready to support this if something else is in. Problem is that different CPCs have different keyboards and we would have to make quite a few versions. Regarding new membranes or a proper adapter, I would support this right away too  :D . In summary, count with me for whatever approach you would like to take!

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #13 on: 17:59, 27 February 16 »
Let´s see if this works... a good cleaning, some masking tape, some silver...  :D

[attachimg=1]

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #14 on: 23:01, 27 February 16 »
And here it is! It will not win a beauty contest (particularly on the sides) but it works very well and it is probably much more sturdy and conductive than in before  :) I will order a couple of spare membranes, anyway.

[attachimg=1]

Since the computer was already open, I cleaned all the connectors with a proper cleaner, specially the ones for the keyboard.

BTW, I discovered that the problem was a bit more complicate than it seemed. So, the numbers not working were due to the membrane BUT the G not working was because I had the mouse adapter connected in the second port for the joystick. Everything is fine using the first port  :picard2:
« Last Edit: 23:03, 27 February 16 by ||C|-|E|| »

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.113
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 3933
  • Likes Given: 410
Re: Keyboard problem in my Plus.
« Reply #15 on: 23:55, 27 February 16 »
Really neat work, but  :picard: for the "brain pause" you had regarding the joystick port. Rule number one when fault finding: Remove everything that doesn't need to be connected.

Bryce.

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #16 on: 00:07, 28 February 16 »
It actually was because of the mixed nature of the problem, but yes, it was a complete  :picard: . I disconnected everything the first time it failed, but the keys were still not working. Then, I decided to plug and unplug the membrane and everything seemed to work but I reconnected the expansions and I found that the G was failing again. So, I thought "hum, this is the classic crap that happens when the membrane starts to fail". In summary, since the numbers were failing as well from time to time I thought that all the problems had a common source. However, after covering the tracks with more silver, I found that everything was working very well until I connected the expansions and the G stopped again. This already made me think that there could be another additional problem  :) .

Good news is that at least the connectors are very clean now and the membrane has a nice additional layer of silver on the tracks. Hopefully, it will last a lot of time like that (fingers crossed) although I am ordering a couple of spare membranes, just in case. I also discovered that tooth paste works wonders as superfine sand in these situations. You almost do not remove any of the silver, but it is possible to see that the paper, towel or whatever you are using becomes a bit gray. It probably removes just a few microns :) .
 
« Last Edit: 00:10, 28 February 16 by ||C|-|E|| »

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.113
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 3933
  • Likes Given: 410
Re: Keyboard problem in my Plus.
« Reply #17 on: 00:36, 28 February 16 »
Anything abrasive on those tracks is a bad idea, even toothpaste. Your solution is much more robust.

Bryce.

Offline ||C|-|E||

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 1.819
  • Country: gb
    • index.php?action=treasury
    • Mundo CPC
  • Liked: 1017
  • Likes Given: 1074
Re: Keyboard problem in my Plus.
« Reply #18 on: 00:40, 28 February 16 »
Actually, I only used the minimal possible amount of tooth paste to clean the the tracks before applying the new silver, the effect was impossible to see by eye  :) . However, I am quite happy with the new layers of metal, the product actually behaves really well and you only need to be a bit patient and remove any excess of silver very carefully when it is dry. It was definitely a good idea to buy it and I still have plenty  :)