CPCWiki forum

General Category => CPCWiki Discussion => Topic started by: Bignumbas on 11:50, 23 May 17

Title: Why does this site grind to a halt randomly?
Post by: Bignumbas on 11:50, 23 May 17
Why does this site grind to a halt randomly?
Especially when I want to post or message.
Are you Europeans punishing us antipodeans?
We have faster internet down under now but its useless on this site when it decides to stop.
100mbits of nada!
Title: Re: Why does this site grind to halt randomly?
Post by: Dagger on 11:53, 23 May 17
It just happens now and then. Does not normally last long so shouldn't stop you enjoying the site
Title: Re: Why does this site grind to a halt randomly?
Post by: pelrun on 13:37, 23 May 17
We have faster internet down under now


Our PM Brian Trumble says that, but it's a bald faced lie...
Title: Re: Why does this site grind to a halt randomly?
Post by: Bryce on 13:39, 23 May 17

Our PM Brian Trumble says that, but it's a bald faced lie...

They do the same trick as in other countries: Give mega fast internet to a few select companies / areas in the middle of a big town, then calculate the average speed for the country and claim that everything has got faster.

Bryce.
Title: Re: Why does this site grind to a halt randomly?
Post by: AMSDOS on 13:59, 23 May 17

Our PM Brian Trumble says that, but it's a bald faced lie...


Funny I can read that while listening to Don Henley online.  :laugh:


Please don't bring the Poliies in here, their all a pack of Bastards!
Title: Re: Why does this site grind to a halt randomly?
Post by: Bignumbas on 15:43, 23 May 17
Our internet down under is not superfast, its much faster in other countries.
The problem here is the distances so we are lucky to get anything.


I worked in IT for the last 30 years and it would seem the hosting is the problem.
Currently  I am a sys admin in volunteer org with a mix of virtual servers, vpns, ms 365 , etc, etc, etc.
Evidently I am to old to be employable

 :(


Is the site being done on a raspberry pi and a dialup modem?
That would explain the bottleneck
If we all gave money would that help fix it?
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 19:38, 28 May 17
Not a money issue, but a much harder one, it would seem. The machine is powerful enough certainly, and bandwidth does not seem to be the problem. We've worked many, many hours on this issue and things have arguably gotten much better than before, but we're out of aces to pull.


Basically, "something" stalls the db every now and then; we haven't been able to pinpoint what causes the problem though - there's no consistency to be found, just random queries becoming very slow to execute and the db crawls to a halt. I've pored over the query queues so long my brain turned into mushed potatoes to no avail...


If you got any ideas, I'll certainly be glad to hear from you :)
Title: Re: Why does this site grind to a halt randomly?
Post by: GeoffB17 on 19:58, 28 May 17
Well, I don't know what system is supporting your server, or the OS, but in my experience regarding a network I look after.


Two things in particular cause the sort of problems you seem to have.


Firstly, from time to time (on schedule) the server will 'wander off' to take care of some housekeeping, re-arranging it's buffers, doing 'shadow copies' or whatever they're called, etc.   These things will be barel;y noticeable if the system is quiet.   If the system is busy at that time, then the users will notice, and also the problem process will take a lot longer!   So it will be more noticeable.   You need to check/review any such 'background' tasks.   That might include what any anti-virus software is doing.


Secondly, regarding specifically the db, what sort of indexing is involved, and how are indexes maintained.   Indexes WILL get in a mess as time goes on, which certainly reduces performance.   The db system may need to do some re-indexing from time to time, there may be some of this happening automatically.   Yes, it's a problem, a system like this will not have much 'quiet' time, as it's being accessed from around the globe.


Geoff
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 20:12, 28 May 17
Here's the thing, though: even with background tasks etc (even with a powerful enough machine and reinstalls) CPU never touches critical levels. SQL will take a significant chunk itself when it's stuck, but the system is ok, overall - nothing else appears to be doing any damage.


Regarding indexing, I have to look into it again, but I had studied that side of the issue and found nothing in particular. But, even if it's done automatically, it wouldn't be as frequent as the problem...


Also something of interest, the problem appeared *after* we moved to a new server (a dedicated box) and copied everything over, but nothing of significance was changed - same OS, same config, so that in itself is puzzling.
Title: Re: Why does this site grind to a halt randomly?
Post by: GeoffB17 on 20:46, 28 May 17
Hmm, two interesting things you say there.


First of all, you refer to system being OK except when SQL is 'stuck'.  Are you referring to the 'cpu useage' figure?  If you see that when there's a problem, and it seems to be a problem with SQL, then the problem DOES appear to be with SQL.   What might SQL be doing.


I'd also wonder about your comment about copying things over, esp the 'same config' thing.   I'm not too familiar with SQL (specifically) so I don't know what sort of things get configured, but if you're using a config set/defined/appropriate for the old machine on a new machine (that is HOW different ?) then isn't that a possible source of problem.   Was SQL reconfigured on the new machine?


Geoff
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 11:57, 29 May 17
Your assumptions are correct - even when SQL is stuck overal CPU usage is not that high, so it's not something else.


There's not much configuring to do regarding the db, to be honest, just installed the engine, imported the db as it was and optimised it (cache levels etc etc). We didn't build it anew. So...
Title: Re: Why does this site grind to a halt randomly?
Post by: GeoffB17 on 01:02, 30 May 17
The only thing I can think to suggest is...


Does the system allow you to force a re-build of all the indexes.   Various things can cause indexes to get messed up, not to the point that they fail to work, but yet past the point where they work efficiently.


I don't know how efficient  the SQL index system is, but I've had problems with other index systems where the overall efficiency (and hence performance) depends on the distribution of the data used for keys.   If you get an imbalance, such that you have a disproportional lump of records with a VERY similar key, then any sort of update to that part of the index becomes a struggle for the system.   How you would tell this, mind you, I cannot say.


Is the system SQL, or is it MySQL, or what?


Geoff
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 01:53, 31 May 17
Please FIX


These are the screen pics before i tried to Log in. after 3 attempts i went to the Third Picture ??


Please FIX




Thanks     Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 09:48, 31 May 17
@Audronic (http://www.cpcwiki.eu/forum/index.php?action=profile;u=1169) : when reporting a problem please use a new thread instead of hijacking another one...


In any case, we're aware of the problem, caused by an update, a solution is in the works.
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 09:57, 31 May 17
@Gryzor (http://www.cpcwiki.eu/forum/index.php?action=profile;u=1)


Oops  Sorry


I thought that it might help Diagnosing some faults ?


Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 10:00, 31 May 17
No, that's a totally different issue :)
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 10:43, 31 May 17
I think the issue has been resolved, can you confirm?
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 10:53, 31 May 17
The only thing I can think to suggest is...

Does the system allow you to force a re-build of all the indexes.   Various things can cause indexes to get messed up, not to the point that they fail to work, but yet past the point where they work efficiently.

I don't know how efficient  the SQL index system is, but I've had problems with other index systems where the overall efficiency (and hence performance) depends on the distribution of the data used for keys.   If you get an imbalance, such that you have a disproportional lump of records with a VERY similar key, then any sort of update to that part of the index becomes a struggle for the system.   How you would tell this, mind you, I cannot say.

Is the system SQL, or is it MySQL, or what?

Geoff
 


The system is running on a Mariadb. IIRC it had some MyISAM tables that were converted to InnoDB but I'm not 100% sure by now.


We did optimize all sorts of things in the db itself quite a while ago; I could perhaps write a script to defrag and optimize all the tables again, but honestly speaking, given the randomness of the issue, I don't think it'll do much good. Well, it can't hurt either...
Title: Re: Why does this site grind to a halt randomly?
Post by: Bryce on 11:10, 31 May 17
I think the issue has been resolved, can you confirm?

Yup, login from the home page is working again.

Bryce.
Title: Re: Why does this site grind to a halt randomly?
Post by: Bignumbas on 11:57, 31 May 17
I sympathise with your troubleshooting woes.
I have just revived two dead cpc's.
Nothing like that feeling when the ready prompt comes up for the first time.
I have also struggled with squid proxy, mysql and websites etc, etc over the years.
Have you looked at '' innodb_adaptive_flushing_method' ?

Sent from my SM-T550 using Tapatalk

Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 12:05, 31 May 17
No, but this is used for high-volume IO bursts. I hope some day we get there, but the traffic is not that high yet :D Plus the db does have all the memory it could need and buffers are pretty much ok...


Yeah, the wonders of troubleshooting!
Title: Re: Why does this site grind to a halt randomly?
Post by: Bignumbas on 16:29, 01 June 17
Yes , I was thinking it was for short floods of data.
When I cannot get any response from the site it lasts for an hour or more.
Just like when a computer crashes.
You said this started on the new server.
This might make it a hardware issue or with linux a combination of both.

Linux kernels and modules can be a problem, sometimes you have to recompile to get compatibility especially with newer hardware.
Maybe a randomly faulty network port.
That could explain the unresponsiveness at random times
Where I work we have a lot of "techs" and occasionaly one plugs a patch cable  back into the same switch.
Really stuffs up a network with a loop back like that.
We just had to change to pfsense to get our incoming vpn to work, could not get server 2012 to do it.
Why? ???
Title: Re: Why does this site grind to a halt randomly?
Post by: Bignumbas on 14:41, 25 June 17
What have you done?
The site does not seem to be freezing up anymore.  :D


???


Dumb luck?
Or really clever stuff?


Cheers
Title: Re: Why does this site grind to a halt randomly?
Post by: arnoldemu on 16:42, 25 June 17
What have you done?
The site does not seem to be freezing up anymore.  :D


 ???


Dumb luck?
Or really clever stuff?


Cheers
It's been stalling for me :(
It never got better :(

Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 17:33, 25 June 17
Hahaha :D


No, indeed, it's the same, and rather random as always. Been meaning to get to your previous post, @Bignumbas (http://www.cpcwiki.eu/forum/index.php?action=profile;u=1936) , but sadly very little time...
Title: Re: Why does this site grind to a halt randomly?
Post by: Bignumbas on 19:46, 25 June 17
Damn, I was thinking you had fixed it.
Maybe they unclogged the cable to Orstralia.
 :D
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 20:01, 25 June 17
Hehe, that could well be one of the things :D
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 02:14, 26 June 17
It's been stalling for me :(
It never got better :(


Same Here. ?


Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 13:23, 28 June 17
An Other 23 Minute wait for the board to do its ? Thing ?


Its still not working properly


Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: Bryce on 14:34, 28 June 17
Amibay is having similar issues at the moment. They think they've narrowed it down to some Chinese search engines that are side-stepping some traffic settings and hogging the entire bandwidth.

Bryce.
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 17:42, 28 June 17
Aha, perhaps it's time to reinstate the server-side ban on Chinese and other Asian IPs...
Title: Re: Why does this site grind to a halt randomly?
Post by: AMSDOS on 06:02, 29 June 17
An Other 23 Minute wait for the board to do its ? Thing ?


Its still not working properly


Ray


Had the same problem and ended up giving up in frustration!  :(
Title: Re: Why does this site grind to a halt randomly?
Post by: keith56 on 06:12, 29 June 17
Aha, perhaps it's time to reinstate the server-side ban on Chinese and other Asian IPs...

Just make sure you put an exception in for my IP!

I notice I always get a "Forbidden" when I try to access the site from my mobile now - it happened from time to time before - so I guess this is some kind of block
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 09:58, 29 June 17
Just make sure you put an exception in for my IP!

I notice I always get a "Forbidden" when I try to access the site from my mobile now - it happened from time to time before - so I guess this is some kind of block


You mean on this site? I don't have a block in place yet, got to research the lists a bit before I implement it. But in any case Japan is not blocked, "only" China and a few other suspect countries (where spam attacks have originated from in the past as well). 
Title: Re: Why does this site grind to a halt randomly?
Post by: keith56 on 16:31, 29 June 17
Here's a screenshot of my phone, the link used to work 80% of the time, but now it never works, don&t know that anythings changed, and it looks like it comes from this site, so I assume it's not ISP blocking?
Title: Re: Why does this site grind to a halt randomly?
Post by: gerald on 18:15, 29 June 17
Here's a screenshot of my phone, the link used to work 80% of the time, but now it never works, don&t know that anythings changed, and it looks like it comes from this site, so I assume it's not ISP blocking?
But your ISP may have assigned you a previously banned IP.
It could help if you can check and report your IP to gryzor when this happen
Title: Re: Why does this site grind to a halt randomly?
Post by: Bignumbas on 01:53, 30 June 17
Hmmmm....the plot thickens.......
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 10:20, 30 June 17
Here's a screenshot of my phone, the link used to work 80% of the time, but now it never works, don&t know that anythings changed, and it looks like it comes from this site, so I assume it's not ISP blocking?


Oops that's no good indeed; it looks like direct server blocking. Next time this happens, can you get your IP and share it with me so I can check? 
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 10:27, 30 June 17
@keith56 (http://www.cpcwiki.eu/forum/index.php?action=profile;u=1886)


Does the same thing happen when you try " cpcwiki.eu " Without the /forum ?


Thanks   Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 11:15, 30 June 17
Different paths can have different restrictions, so indeed maybe he's able to access the wiki but not the forum. I see I do have some blocks from the time a few months back where spammers were trying to get in en masse, so maybe his IP is within the blocked range...
Title: Re: Why does this site grind to a halt randomly?
Post by: keith56 on 12:46, 30 June 17
Does the same thing happen when you try " cpcwiki.eu " Without the /forum ?

Yes it seems so - but don't worry about it for me - I only browse on my phone when I'm supposed to be doing 'other things' so I don't really care if it doesn't work there!
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 13:04, 30 June 17
Nonono, please do help me solve this for you!
Title: Re: Why does this site grind to a halt randomly?
Post by: Shaun M. Neary on 16:12, 30 June 17
I've just gone through this thread, and one potential culprit that hasn't been ruled out, but could play a vital part on the software end of things is a plugin. If there's a bad/out of date plugin installed it can create all sorts of loading issues.

Try disabling all the plugins for a limited period, then monitor the performance. Then slowly add them back one by one, eventually you'll find the one that's causing the issue (if that is indeed, what's causing it), and you can either upgrade it, or replace it with a similar, more compatible one.

Wordpress is a bastard for this, but i'm sure incompatibilities like this aren't just limited to Wordpress either.
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 16:34, 30 June 17
Nah, unfortunately (?) it's not the add-ons. I know this because when we moved servers I did a clean install of the forum, and also the examination of DB data doesn't show *anything* specific...
Title: Re: Why does this site grind to a halt randomly?
Post by: Shaun M. Neary on 17:42, 14 July 17
Taking between 30 seconds to 2 minutes to load a page currently, @Gryzor (http://www.cpcwiki.eu/forum/index.php?action=profile;u=1).

Admit it, you're using a 6128+ to power the server, aren't you?  :laugh:
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 17:43, 14 July 17
Nope, a 1512 actually 😀

Sent from my HTC 10 using Tapatalk

Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 02:57, 15 July 17
@gryzor


When i have problems getting into the /Forum i often just go to the Wiki and this seems to work Most of the time.
I was wondering if there is something unwell with the script that chooses the  /forum.


I hope that this helps


Good luck


Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: Poliander on 14:56, 11 November 17
Any news on this? This week the forum very often did not respond, it seems the problem got worse these days...

 :'(
Title: Re: Why does this site grind to a halt randomly?
Post by: tjohnson on 16:54, 11 November 17
Had it a lot today, just doesn't respond, obviously working right now  :o
Title: Re: Why does this site grind to a halt randomly?
Post by: Dagger on 16:55, 11 November 17
Happens a few times every day, fortunately it normally only last a few minutes

Title: Re: Why does this site grind to a halt randomly?
Post by: reidrac on 17:04, 11 November 17
I've been experiencing the same for quite some time now.

Yes, it works after some minutes, so... I just come back later :)
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 13:57, 13 November 17
No news ever since. Nobody has offered to help unfortunately, and I'm really at my wits' end regarding that issue...
Title: Re: Why does this site grind to a halt randomly?
Post by: GeoffB17 on 17:23, 13 November 17
Hello,
 
I'd LOVE to help, but how?
 
I get this problem frequently. Lasts for a period, then OK again.  To me, shows all the signs of your server/system being busy.   Don't know why.   Could be the server is doing some housekeeping job.   Could be a number of downloads in progress.
 
Do you get any sort of log as to what happens.   So that if, once I can access again, I can send a message saying that 'about time xx:xx the system was not accessible.   Lasted for xx minutes'?   There's no point to doing this unless you've got something to check.
 
Of course, as with any DOS attack, the problem will be compounded because anythime there is a bit of a problem, if there are people trying to log on, and they keep repeat trying, then it just adds to/multiples the problem.
 
Geoff
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 18:30, 13 November 17
I do have external services set up, and I know when the site gets unresponsive.


It's not a DOS attack; in the past we've had a couple but it looked more like spambots gone wild rather than DDOS attacks, and were repelled quite fast (see how an entire continent is disallowed :D ).


The problem has to do with the db; for some reason sometimes, otherwise perfectly normal queries become slow and take a long time to complete. Haven't managed to find out why since it's not specific scripts/functions/calls that cause the trouble!
Title: Re: Why does this site grind to a halt randomly?
Post by: GeoffB17 on 19:17, 13 November 17
I think I asked this before, some time ago.   I seem to remember that you said what the db was.   Can't remember.  But even just db systems need to do housekeeping from time to time, esp if indexes are involved, and sometimes specific sorts of key can lead to problems meaning the system has to do a LOT of work to update the indexes.   Memory available will have an effect as well.   I mean memory specifically available to the db, not just the memory available on the machine.
Geoff
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 19:39, 13 November 17
System specs are fine, memory allocated to db were upped and re-upped to accommodate things, nothing seemed to work. We're on MariaDB.


The weird thing is, the db was lifted and replicated from the previous server where we didn't have such issues (well, we did have performance issues to the server's age, but not db-related); and yet, the problems appeared out of the blue.


To tell you the truth, we've done so many things to try and make the db behave better, that I don't remember all of the details now; if you feel you can help, let's take this off the forum and do it through email - I'm willing to take it up again :)


Thanks!
Title: Re: Why does this site grind to a halt randomly?
Post by: Poliander on 19:46, 13 November 17
Hi Gryzor,

from what I've observed the database theory sounds very valid to me. I believe it might have something to do with an exceeded connection limit which may occur if the application, or some part of, does not close the db connection for some reason. This is of course absolutely not trivial to debug and hard to explain how to do this.

I suppose you're running Ubuntu 14.04 (that's the version with Apache 2.4.7 IIRC). You might want to try mysqlprimer and/or mysqltuner, the DB should be already up and running for a while, then those scripts will fetch the database statistics and give you some hints how to improve your DB tuning.

By the way, switching to nginx is not a bad idea. But that's another thing.

In case you're not sure whether it's really the database, you could use a watchdog/website monitoring (e.g. pingdom or something like that) for tracking that down. Place a plain text "test.txt" file, a "echo ping" test.php script and a test-db.php file which opens (and closes) a db connection somewhere in your document root. Then configure the website monitor to call each of them every few minutes. When the txt file is not reachable, you can forget PHP and the database. If the txt file is reachable, but PHP not, it's probably the PHP FCGI/FPM backend etc.

Cheers
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 20:42, 13 November 17
You're right in your assumptions about the system. I'll try mysqlprimer and mysqltuner, never used them before; got to study a bit and see if we'llneed a backup to restore the system to previous state if it all goes to shit when I run them :D


Pretty skeptical about nginx; always wanted to try it, but preferably not on our valuable production server!


Connection limits, like allocated mem, have been raised again and again (I think in the beginning it was pretty tight, but raising them didn't help). The thing is, queries do finish and connections are closed -it just takes a looong time for it to happen, randomly. I mean, I've seen the thing hanging with such trivial things as fetching a filename to display an attached file, or quering to see how many posts a user has. Go figure. For instance, this page I'm typing on took 0.099 seconds to create with 37 queries. The same page will take a minute or two some times - and then the whole system will freeze for everyone. System resources do hold up - very frequently I'm logged in and I can watch stuff and in general it's very calm - except for the db.


However, employing a watchdog is not a bad idea. I mean, I am pretty sure it's the db's fault, but it never hurts to go back to basics and try and take it from there. Do you have any service in mind? At this point I wouldn't mind paying for a month or two to make things better.


Thanks once again :)


PS I would do it now, but one thing at a time preferably - currenty running a scheduled malware scan - and let me tell you, it takes quite some time to check the almost 900,000 files we've got sitting there!
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 13:09, 15 November 17
Ok.


Over the last few dates I did some tweaking on the databases and on the functionality of the forum and wiki. We did gain some stuff - for instance, a couple of absolutely huge tables were slashed and unnecessary functionality removed to reduce the number of db hits, but it remains to be seen whether these will result in any improvement in real life.


On the other hand, I did run the scripts suggested above. If @Poliander (http://www.cpcwiki.eu/forum/index.php?action=profile;u=203) wants to take a look at the logs and discuss, I'm all ears :)
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 00:48, 16 November 17
@Gryzor (http://www.cpcwiki.eu/forum/index.php?action=profile;u=1).


Ok I have had similar problems on the old setup as the current setup, I believe the it is the same problem that i have had for years.


It fell over today (This connection)  :- Logged in to the site. Then went to put Name /Password in Pressed "Return" wait - wait - wait etc
The original connection started up fast BUT ----


I hope that this is of some help.
I am in a MAC OS 10.11.6


Thanks        Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: GeoffB17 on 01:16, 16 November 17
Just out of interest, what were the 'couple of abs huge tables', what sort of data was being stored in them, how was the data being accessed?   Were the files indexed?

Just because the file is HUGE doesn't make it a problem.   A massive log file, no index, use always just adding new records (on the end) COULD be no problem at all.

Hopefully, I be able to investigate more soon.   My main PC died, waiting for replacement.   Laptop is a help, but it's W7, and less comfortable to use.

Geoff
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 09:25, 16 November 17
Two tables had to do with how the system monitors which threads and which messages you have read or not. With a lot of inactive users, over the years, this becomes problematic since every new post and thread is kept in an entry as unread for them.


On the other hand, there was wiki one caching data for, um, probably 11 years or so. I had my eye on it for quite some time now because I was seeing hits to it being rather slow, but that was not the 'serious' problem we've been experiencing. Just went ahead and did it in anyway.
Title: Re: Why does this site grind to a halt randomly?
Post by: GeoffB17 on 23:49, 17 November 17
Hmm!

I was just thinking, the site has been OK the last few times I've tried to connect.   Is it better?

BUT...

Just now, 9:32pm UK time, I tried to connect, and it just sat thumbing it's nose at me.   Took a few minutes to connect.   Not too long, OK, but still longer than normal.

Was the system doing anything special at that time.   Any hints of specific activity you could identify.

One process I do worry about, as it can cause me problems for my support work.   When the system starts doing the (in Windoze) 'shadow copies'.   I note that Linux systems can do something similar (using LVM, or similar).   Does your system do anything like that.   When, how often?

Such processes should not cause major problems, BUT, this can be dependant on various peculiarities regarding number of files, size of files, and how the files change.   Hence, you could have one setup that copes OK, and another that has problems.

Do you use such a process?

By the way, further to an earlier mention, I've now got a 'new' machine, getting it fully set up.   I say 'new' as it's far from NEW, I do a LOT of DOS stuff, and need a system that allows reasonable DOS capability, and XP is pretty much the last system that works for me, but it's almost impossible to get a NEW system that comes like that.   The 'new' box, though, is looking good!

Geoff
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 00:40, 19 November 17
@Admin


This site Grrrr.
It took 30 Minutes to do 1 Post today.
4 attempts to log in 3 attempts log in as audronic.
It fell over trying to read some postings.
It fell over trying to add a reply.


Very Frustrated
If Possible Please FIX


Thanks    Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 00:52, 19 November 17
You don't say? Oh my, better get on top of this, stat!
Title: Re: Why does this site grind to a halt randomly?
Post by: reidrac on 01:16, 19 November 17
Not sure if add anything to the puzzle, but is not just the forum. I've had the same issue with the wiki; but if there's already some theory that this could be the DB, it would make sense (assuming both forum and wiki share DB server).
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 01:18, 19 November 17
Yup, it's the db alright; been doing north of 100% cpu today, and I'm still hunting the why... :( too late here, heading to bed for now...
Title: Re: Why does this site grind to a halt randomly?
Post by: Audronic on 01:20, 19 November 17
Yup, it's the db alright; been doing north of 100% cpu today, and I'm still hunting the why... :( too late here, heading to bed for now...


Thanks that is appreciated.


Ray
Title: Re: Why does this site grind to a halt randomly?
Post by: steve on 01:35, 19 November 17
I have not been looking at the site much for quite a while now, my unread posts had gotten past 60 pages and the thought of reading them was quite daunting, now my unread posts are down to 4 pages, so, thank you? Gryzor :), did I miss anything earth shattering?.
Title: Re: Why does this site grind to a halt randomly?
Post by: Gryzor on 01:37, 19 November 17
Well, quite a few things actually, but you wouldn't be able to find them probably? [emoji849]

Sorry about that; but of course I guess it did make some sense...

Sent from my HTC 10 using Tapatalk