Author Topic: Emulation Speed Issue  (Read 3580 times)

0 Members and 1 Guest are viewing this topic.

Offline Dirk

  • CPC464
  • **
  • Posts: 5
  • Liked: 0
  • Likes Given: 0
Emulation Speed Issue
« on: 17:52, 08 May 09 »
Hello - I'm new to emulation of the AmstradCPC, however, not new to emulation.  I am running several emulators at full speed w/ a P4 2.8Ghz machine w/ 3Gig RAM on XP Pro.  Unfortunately, when trying to run WinAPE, the speed is at 50% and the fps are 1-3.  Changing to 8 bit greyscale yields no improvement.  Any suggestions on settings to get the emulation up to full speed?
Thank you for the feedback!!

Offline ukmarkh

  • 6128 Plus
  • ******
  • Posts: 1.421
  • Country: england
    • Classic Replay
  • Liked: 307
  • Likes Given: 77
Re: Emulation Speed Issue
« Reply #1 on: 18:31, 08 May 09 »
Did you click the option to use 'direct X' within the Winape options screen?

Offline Dirk

  • CPC464
  • **
  • Posts: 5
  • Liked: 0
  • Likes Given: 0
Re: Emulation Speed Issue
« Reply #2 on: 19:05, 08 May 09 »
I tried with "Direct-X Stretch" checked and without it checked.  The only difference was the screen appearance, however, the speed did not change.
As a side note, WinCPC runs at full speed, but WinAPE appears to be a much better platform if I could get the speed accurate.
Thx

Offline ukmarkh

  • 6128 Plus
  • ******
  • Posts: 1.421
  • Country: england
    • Classic Replay
  • Liked: 307
  • Likes Given: 77
Re: Emulation Speed Issue
« Reply #3 on: 20:24, 08 May 09 »
Are you using Windows 64-bit? Or an older version of Winape32??
« Last Edit: 21:10, 08 May 09 by ukmarkh »

Offline Executioner

  • Supporter
  • 6128 Plus
  • *
  • Posts: 783
  • Country: au
  • WinAPE Developer
    • WinAPE
  • Liked: 391
  • Likes Given: 60
Re: Emulation Speed Issue
« Reply #4 on: 04:29, 11 May 09 »
I have no idea why you would be having speed issues. Your processor is well and truly fast enough. Make sure you have PAL Emulation turned off, speed set to 100% with the Display Every checkbox unchecked. Besides that, I can only suggest it is a conflict with your video card or drivers. What OS and GFX card?

Offline ukmarkh

  • 6128 Plus
  • ******
  • Posts: 1.421
  • Country: england
    • Classic Replay
  • Liked: 307
  • Likes Given: 77
Re: Emulation Speed Issue
« Reply #5 on: 04:35, 11 May 09 »
I have no idea why you would be having speed issues. Your processor is well and truly fast enough. Make sure you have PAL Emulation turned off, speed set to 100% with the Display Every checkbox unchecked. Besides that, I can only suggest it is a conflict with your video card or drivers. What OS and GFX card?

I you remember, I had a similar problem to this about six months back... Winape32 was running dog slow under Windows XP 64-Bit edition. In the end I went back to 32-bit windows and everything worked fine.

Offline Executioner

  • Supporter
  • 6128 Plus
  • *
  • Posts: 783
  • Country: au
  • WinAPE Developer
    • WinAPE
  • Liked: 391
  • Likes Given: 60
Re: Emulation Speed Issue
« Reply #6 on: 04:44, 11 May 09 »
Winape32 was running dog slow under Windows XP 64-Bit edition.

That's understandable, Vista 64 isn't really designed for running 32 bit applications.

Offline Dirk

  • CPC464
  • **
  • Posts: 5
  • Liked: 0
  • Likes Given: 0
Re: Emulation Speed Issue
« Reply #7 on: 22:57, 11 May 09 »
All - thanks for the feedback so far.  Unfortunately, I am running Windows XP Pro 32 bit edition, so that isn't the issue.  My GFX is an ATI Radeon X 1600 w/ current drivers.  PAL Emulation is turned off and speed is set to 100% w Display Every checkbox unchecked.  I am running many other emulators w/o issues, so I'm really stumped.

Offline ukmarkh

  • 6128 Plus
  • ******
  • Posts: 1.421
  • Country: england
    • Classic Replay
  • Liked: 307
  • Likes Given: 77
Re: Emulation Speed Issue
« Reply #8 on: 00:04, 12 May 09 »
All - thanks for the feedback so far.  Unfortunately, I am running Windows XP Pro 32 bit edition, so that isn't the issue.  My GFX is an ATI Radeon X 1600 w/ current drivers.  PAL Emulation is turned off and speed is set to 100% w Display Every checkbox unchecked.  I am running many other emulators w/o issues, so I'm really stumped.

I'm sure I've had this prob in the past, had to first uninstall my graphics driver from device manager, and then install the latest driver I'd earlier downloaded from Nvidia's web site. Everything worked a treat after that, but you must not install the new driver straight over the old.

It's a long shot, but I hope it helps.

Offline demoniak

  • CPC664
  • ***
  • Posts: 84
  • Country: fr
  • Liked: 71
  • Likes Given: 45
Re: Emulation Speed Issue
« Reply #9 on: 10:40, 12 May 09 »
have you tried with PC-CPC ?

Offline Dirk

  • CPC464
  • **
  • Posts: 5
  • Liked: 0
  • Likes Given: 0
Re: Emulation Speed Issue
« Reply #10 on: 01:40, 14 May 09 »
I have tried WinCPC and it runs at full frame rate without issue.  I will try the clean install of the video card to see if that does anything; if not, I guess I'll stick with WinCPC for now.  Thx.....

Offline Dirk

  • CPC464
  • **
  • Posts: 5
  • Liked: 0
  • Likes Given: 0
Re: Emulation Speed Issue
« Reply #11 on: 16:55, 20 May 09 »
Wow - the video card re-install worked!  Now running full fps -  ;D .
Thanks all for the help!

Offline Executioner

  • Supporter
  • 6128 Plus
  • *
  • Posts: 783
  • Country: au
  • WinAPE Developer
    • WinAPE
  • Liked: 391
  • Likes Given: 60
Re: Emulation Speed Issue
« Reply #12 on: 07:17, 21 May 09 »
Wow - the video card re-install worked!  Now running full fps -  ;D .
Thanks all for the help!

Quite strange. WinAPE calls a DirectX function to copy the screen buffer contents to the PC display, and it has an option to wait for completion (which I set to true, so it waits and gives an accurate FPS reading). Maybe a problem with the driver waiting too long, and other emulators don't set this flag, anyway, nice to know it's now fixed.