CPCWiki forum

General Category => Emulators => Topic started by: Dybdal on 23:39, 19 April 16

Title: Winape fullscreen question
Post by: Dybdal on 23:39, 19 April 16
Hey everyone!


Hope im not intruding on your forum but i've got a question that i hope someone can answer.
Been looking at getting into the CPC with a CPC464 (grew up with a c64, got my self a speccy 6 years ago and feel like i want to sink some money into a new toy for the weekends)
Before going into the ZX Spectrum i learned quite abit by messing around with an emulator and i recently got Winape to start getting my feet wet with the CPC but i've run into something i think.. is an issue with the emulator but since i dont really know that much about the CPC i dont actualy know.
The emulator is giving me these small black borders around the Blue Basic screen in fullscreen mode, i've allready tried fiddeling around with my AMD GPU scaling options and that dosnt seem to be whats causing this (it will produce the same black bars regardless if i letterbox the scaling options or if i stretch it out) and that got me wondering.. is this how the CPC outputs its Basic screen? if not.. then what could be casuing this issue with the emulator?


I've attacthed a jpg of the emulator running in fullscreen so you can see what i mean.
Regards: Dybdal
Title: Re: Winape fullscreen question
Post by: roudoudou on 23:42, 19 April 16
Hey everyone!


Hope im not intruding on your forum but i've got a question that i hope someone can answer.
Been looking at getting into the CPC with a CPC464 (grew up with a c64, got my self a speccy 6 years ago and feel like i want to sink some money into a new toy for the weekends)
Before going into the ZX Spectrum i learned quite abit by messing around with an emulator and i recently got Winape to start getting my feet wet with the CPC but i've run into something i think.. is an issue with the emulator but since i dont really know that much about the CPC i dont actualy know.
The emulator is giving me these small black borders around the Blue Basic screen in fullscreen mode, i've allready tried fiddeling around with my AMD GPU scaling options and that dosnt seem to be whats causing this (it will produce the same black bars regardless if i letterbox the scaling options or if i stretch it out) and that got me wondering.. is this how the CPC outputs its Basic screen? if not.. then what could be casuing this issue with the emulator?


I've attacthed a jpg of the emulator running in fullscreen so you can see what i mean.
Regards: Dybdal


i guess the black border is to preserve pixels and avoid aliasing ;)

Title: Re: Winape fullscreen question
Post by: Executioner on 02:45, 20 April 16
WinAPE runs full screen in 800x600 mode. The emulated screen area is 768x540 pixels, 20 there should be 16 pixels each side and 30 pixels top and bottom if the screen is centred (not always the case if menus/control panel are turned on).