Author Topic: Amstrad CP8256  (Read 698 times)

0 Members and 1 Guest are viewing this topic.

Offline greatwolf1283

  • CPC464
  • **
  • Posts: 29
  • Country: gb
  • Liked: 25
  • Likes Given: 4
Amstrad CP8256
« on: 20:42, 04 February 17 »

Need a little bit of help guys.  Went to boot up my 8256 with the CPS8256 attached, and it didn't recognise it.  Thought it might be a problem with the version of CP/M I was using, so tried it with a couple of different versions but none of them worked although the machine still booted.  Tried it with my 9512 and got absolutely nothing - no boot or anything.  Took it off and the machine behaved as per normal.


I did a quick check of the 5V line on the 9512, and without it was running at 5V, however with the CPS8256, it pulled the line down to just over 0.5V.  Tried it in the 8256 and it's still pulling the line down to about 4.7V.  I checked the current draw and it's trying to pull around 250mA of current.  Obviously, any pointers to troubleshoot this would be much appreciated.  In the meantime, I've got a replacement D8253C-5 and Z80A DART on order, as my initial suspicions are that it might be one of those two chips.

Offline JonB

  • 6128 Plus
  • ******
  • Posts: 757
  • Country: gb
  • Liked: 206
  • Likes Given: 48
Re: Amstrad CP8256
« Reply #1 on: 22:13, 04 February 17 »
Are those chips socketed in the interface? If so, pull them and see if the 5v line is still low. If not, replace them one at a time until the 5v goes low again. I think you'll have your culprit.


Then again, it might be that nasty little hack board... MAX232 at the ready... ;)