CPCWiki forum

General Category => NC100, NC200, PCW, PDA600 - the rest of the Family! => Topic started by: Sk8er000 on 11:15, 23 September 19

Title: PC2086/30 stuck at boot
Post by: Sk8er000 on 11:15, 23 September 19
Hello,
Yesterday I've found a PC2086/30 with keyboard keylock keys but I'm a total noob regarding this model.
I've inspected the inside and cleaned a bit (it certainly need a more accurate cleaning and maybe a preventive recap) and it seems ok.
It comes with a standard HDD and the 3.5" floppy drive.
The first time I powered on the pc it turned on for a couple of seconds and then it powered off itself.
On the second try it booted "normally" but after a while I got a message that asks to check the keyboard, mouse and keylock and I can't go on.
The num lock on the keyboard is blinking, the keylock is open, but I don't have the mouse.
Do I need a suitable mouse to go further on the boot sequence or this "issue" is caused from something else?


Thank you in advance

Title: Re: PC2086/30 stuck at boot
Post by: SkulleateR on 00:41, 24 September 19
This beauty should boot without mouse, but if you need one, look on ebay for an old serial PC mouse, it should work


try booting without the keyboard as well


I will have a look at the weekend, I may have an old boot floppy from my Amstrad Euro AT, which should boot the 2086 as well
Title: Re: PC2086/30 stuck at boot
Post by: JohnElliott on 00:53, 24 September 19
My recollection is that it'll boot without the mouse, but needs the keyboard. If you do get a serial mouse be sure to plug it into the serial port, not the mouse port!
Title: Re: PC2086/30 stuck at boot
Post by: Sk8er000 on 01:04, 24 September 19

Thank you everyone for the answers! ;D
If it can boot without the mouse then I've got to figure out where con be the issue. No matter what I've tried but I always get the following message:

Quote
Amstrad plc.
Last used at 00.00 on 01 January 1980.
Check keylock switch, keyboard and mouse.
The times is always 00.00 but I'm running the pc without the 4 AA batteries.
Since the keyboard led is blinking I'll try to check with the tester if the keylock is closing and opening properly.
If can be helpful I'll post some images of the motherbard
Title: Re: PC2086/30 stuck at boot
Post by: rambler on 01:24, 24 September 19
Maybe this link might help you:
http://www.freetimeweb.nl/home/computer/alt/lawsons-amstrad-computer_site/web.ukonline.co.uk/cliff.lawson/quest5.htm#Q0128 (http://www.freetimeweb.nl/home/computer/alt/lawsons-amstrad-computer_site/web.ukonline.co.uk/cliff.lawson/quest5.htm#Q0128)


or this one:
http://www.cpcwiki.eu/forum/nc100-nc200-pcw-pda600/pc2086-keylock/msg120480/#msg120480 (http://www.cpcwiki.eu/forum/nc100-nc200-pcw-pda600/pc2086-keylock/msg120480/#msg120480)
Title: Re: PC2086/30 stuck at boot
Post by: Sk8er000 on 17:22, 24 September 19
So, today I've inspected a little deeper the PC.
I've checked the keylock switch with the tester and it seems to work properly.
Here are some pics of the motherboard:


http://imgur.com/a/6SrXd1g (http://imgur.com/a/6SrXd1g)


The first time I've powered on the PC after a couple of days it turned off itself alfter a couple of seconds like the first time. Tried to power on some seconds after and it booted. The first boot is quite different from the other beacuse it says that the disk is not ready and to change the batteries (that are not present). The other boots are showed on this video:


https://drive.google.com/file/d/16M00T2WfdAaZDLXsOtgjTEpamdOg4hLy/view?usp=drivesdk (https://drive.google.com/file/d/16M00T2WfdAaZDLXsOtgjTEpamdOg4hLy/view?usp=drivesdk)




I've tried to search for some sort of shortcut to see if there's something regardin the mouse byybass but with no luck
Title: Re: PC2086/30 stuck at boot
Post by: Sk8er000 on 09:48, 11 October 19
Little update, I've bought a new old stock mouse but the message is still the same this time "hard disk not ready" remains at every boot but i got "Check keylock switch, keyboard and mouse" as last message