CPCWiki forum

General Category => NC100, NC200, PCW, PDA600 - the rest of the Family! => Topic started by: tjohnson on 11:35, 18 May 17

Title: Pcw boot issues
Post by: tjohnson on 11:35, 18 May 17
Does anyone have any experience of pcw8512 booting.  When switching on the PCW an all green screen is shown.  When I insert the boot disk the disk drive head moves and then the screen goes completely blank before the whole thing repeats over  This repeats until it eventually times out, stops and then I hear three beeps.  I have replaced the belt in the drive and have tested the drive in my 6128.  I can cat the boot disk in my 6128 and it appears ok.  I have tried to build a new disk using images from here and the same thing happens.  I think the beep error indicates invalid boot disk but I'm fairly confident the disk and the drive is good as I say I tested them, however the action of the drive does seem to act like it is not reading the disk.  I wonder if there is an issue with the mainboard that can cause this.  I will upload a video.
Title: Re: Pcw boot issues
Post by: GeoffB17 on 18:59, 18 May 17
Hmm, I've booted my PCW a few times.  99.9% OK.

Can't really make much sense of your message.

Have you had the machine boot OK before.

What SHOULD happen, is that you should get the clicks as the machine reads the disk, and while the system is being loaded, you should get blue bars a few mm wide appear down the screen, to about 2/3rds of the way down if things have loaded OK.

Do you get those bars, any of them?

You say the drive and the disk are OK.   Why do you say that?  Clearly something is wrong.

The beeps are certainly an indication that the read/load has failed in some way.

If there were no bars at all, then nothing has been read.   This suggests the drive is faulty, or the disk cannot be read at all.

It is usual for the rubber drive band to have failed, I take it that you have replaced this?   Please confirm how you believe that the drive is OK.

The disk needs to be a SSSD disk, with a format capacity of about 173k.   There must be a valid boot sector (the first sector of the first track).   When the code here loads, it caused the system to search for the system file, and load that.   The file will be something JnnCPM3.EMS, where nn is the version number of the system file, it's fairly large and takes a few seconds to load.

Again, why are you sure the disk is OK, does it boot OK on another machine?   Is the disk an AMSTRAD boot disk, or have you 'made' it yourself?   If you cannot get the machine to boot in the first place, then how have you verified the disk and it's contents.

The drives and the disks are usually pretty reliable.   The problem could turn out to be something pretty simple.

Oh, I'm assuming that it's the CP/M boot disk that you're trying.   Have you got the LocoScript system disk as well.   Have you tried to boot from that, that should boot in a very similar way.   If you have a number of disks, that are there any marked 'Start of Day', these might also be bootable.

I'm sure that people here will help if they can. but please supply a bit more information.

Title: Re: Pcw boot issues
Post by: tjohnson on 01:16, 19 May 17
Hi Geoff, thanks for the advice, after more testing I have determined it is a slightly out of calibration FDD, I swapped it out for another and it now works.
Title: Re: Pcw boot issues
Post by: GeoffB17 on 21:12, 19 May 17
In case you need to, I understand that it is possible to re-calibrate with not much more than a known good disk.

I believe Bryce can do it, maybe he's passed on some of his magic to others?

Title: Re: Pcw boot issues
Post by: tjohnson on 19:38, 20 May 17
I get the impression that calibration involves releasing the worm drive screws and rotating the drive.  The screws on my drive as fixed with screwlock so will need to get some heat on them to do this.  Think I'll give it a go