Author Topic: Amstrad DMP2000 printer - sort of working!  (Read 760 times)

0 Members and 1 Guest are viewing this topic.

Offline satchman2000

  • CPC464
  • **
  • Posts: 29
  • Country: gb
  • Liked: 10
  • Likes Given: 3
Amstrad DMP2000 printer - sort of working!
« on: 20:44, 12 September 20 »
hi folks


I recently picked up a DMP2000 printer. After some cleaning and TLC, it looks to be working fine. All buttons respond as expected, free print head movement etc. Printer self test prints results.


So far so good!


However.. once connected to the CPC 464, it won't print. If I try:
print #8,"hello world"


The "on line" light goes off, the print head moves as if to print, but then does nothing. The On line light comes back on.


I get the same response trying to print from Easi-Amsword.


It's as if the printer received the command, but it got lost in translation. Its a brand new printer cable I made myself from a tutorial on this site. I've checked all connections on the cable using a multimeter and there are no shorts; the pins have punctured the cable cleanly and seem to be making good connection.


I set the dip switches as per the manual for basic printing in the UK, so should be good.


Any ideas? Any other tests I can try?


thanks in advance,


Dave

Offline satchman2000

  • CPC464
  • **
  • Posts: 29
  • Country: gb
  • Liked: 10
  • Likes Given: 3
Re: Amstrad DMP2000 printer - sort of working!
« Reply #1 on: 01:04, 19 October 20 »
In case anyone was interested, got a replacement printer with official PL 1 printer lead and it works fine!


The original printer still doesn’t work with the Amstrad but oddly works with my Amiga!

Offline Animalgril987

  • Supporter
  • CPC6128
  • *
  • Posts: 175
  • Country: gb
  • Liked: 83
  • Likes Given: 199
Re: Amstrad DMP2000 printer - sort of working!
« Reply #2 on: 12:48, 13 March 21 »
Does the original printer work with the new cable?